网易游戏注册events消息值构造算法

Lazy心宿 2017-10-13 16:13 1259次浏览

网易游戏注册events消息值构造算法

岁月写的,转载

.版本 2

.局部变量 user, 文本型
.局部变量 pwd, 文本型
.局部变量 code, 文本型

user = “a13431899788”
pwd = “a123456”
code = “svmu” ‘这是验证码
输出调试文本 (getEvents (user, pwd, code))


.子程序 getEvents, 文本型
.参数 user, 文本型
.参数 pwd, 文本型
.参数 code, 文本型
.局部变量 t, 文本型
.局部变量 mouseN, 整数型
.局部变量 mouseL, 文本型
.局部变量 keyN, 整数型
.局部变量 keyL, 文本型
.局部变量 keyCode, 整数型, , "0"
.局部变量 n, 整数型
.局部变量 i, 整数型
.局部变量 j, 文本型
.局部变量 m, 整数型
.局部变量 events, 文本型

置随机数种子 ()
mouseN = 取随机数 (2, 6)
t = 到大写 (user + 字符 (9) + pwd + 字符 (9) + code)
keyN = 取文本长度 (t)
.计次循环首 (keyN, i)
    加入成员 (keyCode, 取代码 (取文本中间 (t, i, 1), ))
.计次循环尾 ()
.计次循环首 (mouseN, i)
    .如果 (i = 1)
        m = 取随机数 (2000, 5000)
    .否则
        m = m + 取随机数 (199, 1999)
    .如果结束
    mouseL = mouseL + “[1,” + 到文本 (m) + “],”
.计次循环尾 ()
mouseL = 取文本左边 (mouseL, 取文本长度 (mouseL) - 1)
.计次循环首 (keyN, i)
    n = keyCode <i>
    .判断开始 (n ≥ 48 且 n ≤ 57 或 n ≥ 96 且 n ≤ 105)
        j = “D”
    .判断 (n ≥ 65 且 n ≤ 90)
        j = “S”
    .默认
        j = “T”
    .判断结束

    .如果 (i = 1)
        m = 取随机数 (2000, 5000)
    .否则
        m = m + 取随机数 (199, 1999)
    .如果结束
    keyL = keyL + “[\'” + j + “\',” + 到文本 (m) + “],”
.计次循环尾 ()
keyL = 取文本左边 (keyL, 取文本长度 (keyL) - 1)
events = “{\'scrSx\':0,\'scrSy\':0,\'winLF\':0,\'winSx\':0,\'winSy\':0,\'winPx\':0,\'winPy\':0,\'ursSx\':0,\'ursSy\':0,\'ursPx\':0,\'ursPy\':0,\'pw1Sx\':0,\'pw1Sy\':0,\'pw1Px\':0,\'pw1Py\':0,\'check\':2,\'mouseN\':” + 到文本 (mouseN) + “,\'mouseL\':[” + mouseL + “],\'mouseT\':0,\'keyN\':” + 到文本 (keyN) + “,\'keyL\':[” + keyL + “],\'keyT\':0}”
返回 (events)



<i>
163-reg_events计算.rar