易语言高级表格及超级列表框导出EXCEL

易语言高级表格及超级列表框导出EXCEL

 

源代码 复制在易语言中粘贴即可

 

 

.版本 2
.支持库 eGrid
.支持库 eExcel2000
.支持库 eAPI
.支持库 iext

.子程序 高级表格保存为excel, , 公开, 解决大数字导出为科学计数的问题
.参数 保存文件名, 文本型
.参数 高级表格, 高级表格
.参数 Excel程序, Excel程序
.参数 Excel工作簿, Excel工作簿
.局部变量 高表行数, 整数型
.局部变量 高表列数, 整数型
.局部变量 列前字母, 文本型

Excel程序.创建 ()
Excel工作簿.置程序 (Excel程序)
Excel工作簿.表格序号 = 1
Excel工作簿.激活 ()
.计次循环首 (高级表格.行数, 高表行数)
    .计次循环首 (高级表格.列数, 高表列数)
        列前字母 = 字符 (96 + 高表列数)
        Excel工作簿.首单元格 = 列前字母 + 到文本 (高表行数)
        Excel工作簿.尾单元格 = 列前字母 + 到文本 (高表行数)
        Excel工作簿.内容格式 = “@”
        Excel工作簿.内容 = 到文本 (高级表格.取数据 (高表行数 - 1, 高表列数 - 1))
    .计次循环尾 ()
.计次循环尾 ()
Excel工作簿.保存 (保存文件名)
Excel工作簿.释放 ()
Excel工作簿.关闭 ()
Excel程序.释放 ()
Excel程序.退出 ()
终止进程 (“Excel.exe”)


.子程序 超级列表框保存为excel, , 公开, 解决大数字导出为科学计数的问题
.参数 保存文件名, 文本型
.参数 超级列表, 超级列表框
.参数 Excel程序, Excel程序
.参数 Excel工作簿, Excel工作簿
.局部变量 行号, 整数型
.局部变量 列号, 整数型
.局部变量 列前字母, 文本型

Excel程序.创建 ()
Excel工作簿.置程序 (Excel程序)
Excel工作簿.表格序号 = 1
Excel工作簿.激活 ()
.计次循环首 (超级列表.取列数 (), 列号)  ' 此处取出超级列表框的列标题
    列前字母 = 字符 (96 + 列号)
    Excel工作簿.首单元格 = 列前字母 + 到文本 (“1”)
    Excel工作簿.尾单元格 = 列前字母 + 到文本 (“1”)
    Excel工作簿.内容格式 = “@”
    Excel工作簿.内容 = 到文本 (超级列表.取列标题 (列号))
.计次循环尾 ()
.计次循环首 (超级列表.取表项数 (), 行号)  ' 此处取出超级列表框的表项内容
    .计次循环首 (超级列表.取列数 (), 列号)
        列前字母 = 字符 (96 + 列号)
        Excel工作簿.首单元格 = 列前字母 + 到文本 (行号 + 1)  ' 从标题的下一行开始写入表项数据
        Excel工作簿.尾单元格 = 列前字母 + 到文本 (行号 + 1)  ' 从标题的下一行开始写入表项数据
        Excel工作簿.内容格式 = “@”
        Excel工作簿.内容 = 到文本 (超级列表.取标题 (行号 - 1, 列号 - 1))
    .计次循环尾 ()
.计次循环尾 ()
Excel工作簿.保存 (保存文件名)
Excel工作簿.释放 ()
Excel工作簿.关闭 ()
Excel程序.释放 ()
Excel程序.退出 ()
终止进程 (“Excel.exe”)

 

发表评论 / Comment

用心评论~