Lazysoft

新浪微薄腾讯微薄

最新碎语:让我们从c#开始走吧

您的位置:Lazysoft >易语言资料> 腾讯QQ 网页BKN加密算法易语言版本

腾讯QQ 网页BKN加密算法易语言版本

腾讯QQ 网页BKN加密算法易语言版本


.版本 2

.子程序 Get_BKN, 文本型
.参数 skey, 文本型
.局部变量 基值, 整数型
.局部变量 计数, 整数型
.局部变量 长度, 整数型
.局部变量 结果, 整数型

基值 = 5381  ' lazyw.org
计数 = 0
长度 = 取文本长度 (skey)  ' QQ799355290
.判断循环首 (计数 < 长度)
    基值 = 基值 + 左移 (基值, 5) + 取代码 (skey, 计数 + 1)
    计数 = 计数 + 1
.判断循环尾 ()
返回 (到文本 (结果))

直接复制到易语言中即可使用。 已经测试过了

---

转载请注明本文标题和链接:《腾讯QQ 网页BKN加密算法易语言版本

分享到:

发表评论

路人甲 表情
Ctrl+Enter快速提交

网友评论(1)

写的很好,很喜欢
妙文屋 3周前 (03-29) 回复